40 lines
900 B
Nix
40 lines
900 B
Nix
{
|
|
disko.devices = {
|
|
disk.main = {
|
|
device = "/dev/nvme0n1";
|
|
type = "disk";
|
|
content = {
|
|
type = "gpt";
|
|
partitions = {
|
|
esp = {
|
|
name = "esp";
|
|
size = "1G";
|
|
type = "EF00";
|
|
content = {
|
|
type = "filesystem";
|
|
format = "vfat";
|
|
mountpoint = "/boot";
|
|
mountOptions = ["umask=0077"];
|
|
};
|
|
};
|
|
luks = {
|
|
size = "100%";
|
|
label = "luks";
|
|
content = {
|
|
type = "luks";
|
|
name = "crypted";
|
|
settings = {
|
|
allowDiscards = true;
|
|
};
|
|
content = {
|
|
type = "filesystem";
|
|
format = "ext4";
|
|
mountpoint = "/";
|
|
};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
}
|